Debian gnome problem

Ζητήστε ή προσφέρετε βοήθεια.
Άβαταρ μέλους
tasosos
Member
Member
Δημοσιεύσεις: 120
Εγγραφή: 22 Νοέμ 2005, 19:03
Distro: Debian
Τοποθεσία: Ιωάννινα

Debian gnome problem

Δημοσίευση από tasosos » 31 Μαρ 2013, 23:06

Για πείτε μου εσείς απ'το ilug που ξέρετε πολλά και ο νους σας κατεβάζει...
Έχω εδώ ένα πρόβλημα με το gnome(μάλλον)

Έχω έναν i7 με την intel HD 4000 vga και πριν καιρό έπαιζα με αυτήν.
00:02.0 VGA compatible controller: Intel Corporation Xeon E3-1200 v2/3rd Gen Core processor Graphics Controller (rev 09)
[Όλα καλά.
Πρίν 1-2 μήνες έβαλα μια ATI 7770 με τον αντίστοιχο driver(fglrx) και επίσης όλα καλά.
Χτές έβγαλα την 7770 και ήθελα να είμαι πλέον με την intel.

Ε πάω να κάνω login σε gnome-shell αλλά δεν ανοίγει τίποτα. Βλέπω σκέτο το background.

Έσβησα και το xorg.conf και τα ίδια. Σε gnome-classic παίζουν όλα κανονικά.

1)Όταν έβγαλα την 7770 έκανα remove και τον fglrx και γκρίνιαζε να κάνω apt-get autoremove ε και δεν υπήρχε χρόνος οπότε το έκανα χωρίς να δω τι στο καλό θα σβήσει. Παίζει να έκοψε εκεί τίποτα που χρειαζόταν.
2)όταν δίνω startx κάτι warnings πετάει
The XKEYBOARD keymap compiler (xkbconf) reports
Compat map for group 3 redefined
Using new definition
Errors are not fatal to the X server

Έχω κάνει reinstall xserver-xorg, x-window-system-core, gnome, gnome-core αλλά τα ίδια. Τo distro ήταν wheezy το πήγα και σε sid αλλά πάλι το ίδιο.

Κάτι χάνω εδω πέρα, βοηθάτε δεν ξέρω τι άλλο να κάνω. Θα βάλω windows 8 ή KDE. Δεν ξέρω τι είναι χειρότερο!

Άβαταρ μέλους
Fuzz
Sr. Member
Sr. Member
Δημοσιεύσεις: 364
Εγγραφή: 22 Νοέμ 2005, 12:09
Distro: Debian
Τοποθεσία: Nowhere
Επικοινωνία:

Re: Debian gnome problem

Δημοσίευση από Fuzz » 01 Απρ 2013, 01:27

Μπορείς να βρεις τα logs του package manager σου στο /var/log/apt/history και από εκεί να δεις αν κάτι εγκαταστάθηκε η απ-εγκαταστάθηκε. Γενικά ο fglrx καλό είναι να αποφεύγεται, είναι ένα χάλι και μισό, οι open source drivers για ATI/AMD είναι αξιοπρεπείς και όποτε μπορείς προτίμησε αυτούς.
Αν δεν βγάλεις άκρη κάνε paste εδώ όλο το log του Xorg.

Άβαταρ μέλους
tasosos
Member
Member
Δημοσιεύσεις: 120
Εγγραφή: 22 Νοέμ 2005, 19:03
Distro: Debian
Τοποθεσία: Ιωάννινα

Re: Debian gnome problem

Δημοσίευση από tasosos » 01 Απρ 2013, 14:13

Δεν βρήκα κάτι να απεγκαταστήθηκε με το autoremove και να μην το ξαναεγκατέστησα μετά.

Επίσης :
lshw -C display
*-display
description: VGA compatible controller
product: Xeon E3-1200 v2/3rd Gen Core processor Graphics Controller
vendor: Intel Corporation
physical id: 2
bus info: pci@0000:00:02.0
version: 09
width: 64 bits
clock: 33MHz
capabilities: msi pm vga_controller bus_master cap_list rom
configuration: driver=i915 latency=0
resources: irq:55 memory:f7800000-f7bfffff memory:e0000000-efffffff ioport:f000(size=64)
Επισυνάπτω το Xorg.0.log
Xorg.0.log
Δεν έχετε τα απαραίτητα δικαιώματα για να δείτε τα συνημμένα αρχεία σε αυτή τη δημοσίευση.

Άβαταρ μέλους
Fuzz
Sr. Member
Sr. Member
Δημοσιεύσεις: 364
Εγγραφή: 22 Νοέμ 2005, 12:09
Distro: Debian
Τοποθεσία: Nowhere
Επικοινωνία:

Re: Debian gnome problem

Δημοσίευση από Fuzz » 02 Απρ 2013, 02:14

Το log του xorg δεν δείχνει κανένα error (τα errors είναι marked σαν (ΕΕ) ), οπότε κατι άλλο έσπασε και όχι ο xorg. Υποψιάζομαι κάποιο openGL lib που αντικατέστησε ο fglrx

Άβαταρ μέλους
IrDA
Sr. Member
Sr. Member
Δημοσιεύσεις: 413
Εγγραφή: 15 Δεκ 2005, 21:11
Distro: Debian Testing
Επικοινωνία:

Re: Debian gnome problem

Δημοσίευση από IrDA » 02 Απρ 2013, 10:08

Το gnome 3 είναι gpu accelerated ενώ το classic δεν είναι λογικά κάτι τέτοιο που λέει ο fuzz θα είναι ...

Άβαταρ μέλους
tasosos
Member
Member
Δημοσιεύσεις: 120
Εγγραφή: 22 Νοέμ 2005, 19:03
Distro: Debian
Τοποθεσία: Ιωάννινα

Re: Debian gnome problem

Δημοσίευση από tasosos » 02 Απρ 2013, 14:23

Οκ με τον έναν ή τον άλλον τρόπο θα το στρώσω. Thanks!

Απάντηση

Μέλη σε σύνδεση

Μέλη σε αυτήν τη Δ. Συζήτηση: Δεν υπάρχουν εγγεγραμμένα μέλη και 1 επισκέπτης