Σελίδα 1 από 1

Πρόβλημα με το wireless στο γραφείο

Δημοσιεύτηκε: 25 Σεπ 2009, 11:12
από IrDA
Έχω ένα πρόβλημα με τα wireless γενικά. Στο σπίτι έχω ένα router που μοιράζει με dhcp δίκτυο και όλα λειτουργούν οκ. Στο γραφείο έχουμε 2 access points το ένα έχει dhcp και στο άλλο χρειάζεται να έχεις στατική ip. Το πρόβλημα ανακύπτει με αυτό που έχει στατική ip και το NetworkManager.

Έχω θέσει τις πληροφορίες στο NetworkManager κάνει connect αλλά δεν βλέπει δίκτυο στον έξω κόσμο γενικά εκτώς από χτες που δούλεψε χωρίς να ξέρω τι είχα κάνει για να το ξανακάνω ;). Δίκτυο παίρνει μέσω ενός linux box που έχει masqeurading. Το setup του linux box είναι σωστό γιατί εκτώς από μένα που πείρα λίγο νετ χτες παίρνουν και οι υπόλοιποι με φορητούς στο γραφείο. Το πρόβλημα λοιπόν είναι σε μένα, μου είχε πει κάποτε και ο mikeg να κλείνω το service του avahi που ποτέ δεν έχω μάθει τι κάνει. Τεσπά, ακούω προτάσεις ...

Re: Πρόβλημα με το wireless στο γραφείο

Δημοσιεύτηκε: 25 Σεπ 2009, 11:41
από IrDA
Μόλις το πρόβλημα έγινε πιο δυσεπίλυτο. Αφού παίζω με το avahi (που έμαθα τι είναι τελικά ...) και συνεχίζω να κάνω ping από εδώ και από κει τα ιδιωτικά ip και τους nameservers του uni κτλ κτλ έκανα και ping από το linux box στον φορητό μου. Τώρα το ποστ γίνεται από τον φορητό που πήρε νετ κανονικά ... Ξέρει κανείς τι μπορεί να παίζει ???

Re: Πρόβλημα με το wireless στο γραφείο

Δημοσιεύτηκε: 25 Σεπ 2009, 11:43
από IrDA
Και για όσους βιαστούν ip και routes κτλ κτλ όλα είναι ΟΚ όπως θα έπρεπε να είναι.

Re: Πρόβλημα με το wireless στο γραφείο

Δημοσιεύτηκε: 25 Σεπ 2009, 12:04
από alx
Ποιο πρωτόκολλο (WEP, WPA κλπ.) χρησιμοποιείται στο δίκτυο; Όταν η σύνδεση είναι προβληματική, ο NetworkManager βγάζει κάποια σχετική πληροφορία (στο dmesg για παράδειγμα); Μπορείς να δοκιμάσεις να συνδεθείς από κονσόλα με το iwconfig ή το wpa_supplicant;

Re: Πρόβλημα με το wireless στο γραφείο

Δημοσιεύτηκε: 25 Σεπ 2009, 15:03
από IrDA
η κωδικοποίηση είναι WEP. Δεν έχει πρόβλημα το να συνδεθεί στο access point, συνδέεται κανονικά απλά με το ip του και το gateway κανονικά απλά δεν παίρνει δίκτυο εξωτερικό. Παίρνει μόνο όταν από το μηχάνημα που κάνει routing το κάνω ping.

Re: Πρόβλημα με το wireless στο γραφείο

Δημοσιεύτηκε: 25 Σεπ 2009, 15:49
από kargig
Είτε βιαστούμε να το πούμε είτε όχι, το σίγουρο είναι πως το πρόβλημα είναι εκεί.

Επίσης αποκρυπτογράφησε λίγο το:
Δεν έχει πρόβλημα το να συνδεθεί στο access point, συνδέεται κανονικά απλά με το ip του και το gateway κανονικά απλά δεν παίρνει δίκτυο εξωτερικό. Παίρνει μόνο όταν από το μηχάνημα που κάνει routing το κάνω ping.
γιατί δεν καταλαβαίνω (τουλάχιστον εγώ) τι θέλεις να πεις.

Πολύ συχνό λάθος είναι οι 2 κάρτες (ethernet και wireless) να έχουν IP από το ίδιο subnet (manually) και να έχουν δηλωμένο και default gateway και οι 2. Με αποτέλεσμα να γίνεται χάος.

Πρέπει να υπάρχει πάντα μόνο ένα default gateway δηλωμένο και όχι ένα default gateway για κάθε κάρτα.
Σου συνιστώ να διαβάσεις το: http://wiki.hellug.gr/index.php/Network ... mini_Howto (ή το http://forum.hellug.gr/index.php?topic=1855.0) για να εντοπίσεις το πρόβλημά σου.

Re: Πρόβλημα με το wireless στο γραφείο

Δημοσιεύτηκε: 25 Σεπ 2009, 16:26
από IrDA
Ξέρω πως δεν το περιγράφω καλά. Συγγνώμη για αυτό ;)

Το configuration του μηχανήματος που κάνει το routing (linux box) παίζει κανονικά εδώ και 3 χρόνια, μοιράζει νετ σε 6 φορητούς υπολογιστές μέσω ενός wireless access point. Έχει δύο κάρτες δικτύου, η πρώτη έχει ένα public ip και η δεύτερη το 192.168.1.250.

Στους φορητούς έχουμε manual config και θέτουμε ένα ip 192.168.1.Χ με gateway το 192.168.1.250. NAmeservers χρησιμοποιούμε του πανεπιστημίου.

Στον φορητό μου που τρέχει linux μέσω του NetworkManager βρίσκω το SSID του wireless του γραφείου και κάνω connect. Μου ζητάει τα στοιχεία, τα βάζω, και παίρνω το ip μου κανονικά (που είναι της μορφής 192.168.1.Χ). Κάνοντας route -n βλέπω πως το routing είναι και αυτό κανονικα σεταρισμένο με default το 192.168.1.250. Τσεκαρισμένα επίσης και από το ifconfig & nm-tool.

Μπορώ να κάνω ping το δίκτυο 192.168.1.Χ και το gateway αλλά δεν μπορώ να κάνω ping οτιδήποτε public. Δεν βγαίνω προς τα έξω δλδ.

Το πρόβλημα αυτό λίνεται εάν κάνω ping τον φορητό από το linux box. Μπορεί σε όλη τη διαδικασία να κάνω κάπου λάθος για αυτό θέλω τα φώτα σας ...

Το λάθος που λες kargig δεν το έχω εγώ στο config μου. Μόνο ένα είναι το default gateway.

Επίσης όλα αυτά που λέει στο wiki (δλδ και το /etc/resolv.conf είναι σωστό) τα έχω κάνει απλά βάζω αντί για τον nameserver του OTE τον koukos.med.uoi.gr  8) .

Re: Πρόβλημα με το wireless στο γραφείο

Δημοσιεύτηκε: 25 Σεπ 2009, 17:23
από alx
IrDA έγραψε: Το πρόβλημα αυτό λίνεται εάν κάνω ping τον φορητό από το linux box. Μπορεί σε όλη τη διαδικασία να κάνω κάπου λάθος για αυτό θέλω τα φώτα σας ...
Για να δω αν κατάλαβα καλά:
  • Το linux box λειτουργεί σαν γέφυρα ανάμεσα στο ιδιωτικό δίκτυο του γραφείου (192.168.1.xxx) και του πανεπιστημίου.
  • Το access point δεν τρέχει nameserver, είναι ρυθμισμένο να προωθεί αυτές τις αιτήσεις στο 192.168.1.250.
Όταν υφίσταται το πρόβλημα:
  • Μπορείς να δεις και να συνδεθείς σε οποιοδήποτε μηχάνημα είναι στο 192.168.1.xxx, συμπεριλαμβανομένων και του AP και του 192.168.1.250, αλλά πουθενά αλλού.
  • Έστω ότι έχεις σηκώσει το interface με IP 192.168.1.5. Μόλις κάποιος κάνει από το 192.168.1.250 ping στο 192.168.1.5, είσαι πλέον σε θέση να συνδεθείς οπουδήποτε στο internet (και στο δίκτυο του πανεπιστημίου).
ΑΝ έχουν έτσι τα πράγματα, μήπως κάποια πακέτα κόβονται κατά τη μία ή την άλλη φορά, ή μήπως κάποιος daemon δεν ξεκινάει όταν πρέπει; Θες να δοκιμάσεις να απενεργοποιήσεις προσωρινά τον NetworkManager και να δοκιμάσεις να κάνεις όλες τις ρυθμίσεις και τη σύνδεση χειροκίνητα από κονσόλα, για να αποκλείσουμε κάποιο bug σε αυτόν;
Αν ισχύει η πρώτη υπόθεση, ίσως θα πρέπει να το κοιτάξεις με το wireshark και το tcpdump.

Re: Πρόβλημα με το wireless στο γραφείο

Δημοσιεύτηκε: 25 Σεπ 2009, 18:32
από kargig
Όταν κάνεις ping την IP 192.168.1.250 μπορείς να κάνεις ping και την public IP που έχει ο server στην κάρτα που κοιτάει το internet ή όχι ?

[offtopic]
Άσχετο με το πρόβλημά σου, αλλά έχω την εντύπωση πως οι ο koukos.X.uoi.gr δεν λειτουργεί ως name server. Είναι το interface του router/vlan για το subnet X. Οι NS του UOI είναι οι 195.130.120.120 και 195.130.120.110 αν θυμάμαι καλά...
[/offtopic]

Re: Πρόβλημα με το wireless στο γραφείο

Δημοσιεύτηκε: 25 Σεπ 2009, 20:07
από IrDA
Τα πράγματα είναι όπως τα είπε ο Alx.

Αρχικά βλέπω μόνο το εσωτερικό δίκτυο (192.168.1.Χ) χωρίς να μπορώ να κάνω ping ούτε και το public ΙΡ. Στην συνέχεια και αφού από το 192.168.1.250 κάνω ping το 192.168.1.5 μπορώ να δω προς τα έξω.

Θα το προσπαθήσω Άλεξ από δευτέρα που θα πάω γραφείο και θα γράψω εδώ τα αποτελέσματα.

by the way έχεις δίκιο για τον κούκο ;)