Ubuntu: Από Dapper Drake σε Edgy Eft.

Ζητήστε ή προσφέρετε βοήθεια.
Άβαταρ μέλους
Indy
Jr. Member
Jr. Member
Δημοσιεύσεις: 87
Εγγραφή: 29 Νοέμ 2005, 15:29
Distro: Windows
Τοποθεσία: Θεσσαλονίκη
Επικοινωνία:

Ubuntu: Από Dapper Drake σε Edgy Eft.

Δημοσίευση από Indy » 26 Οκτ 2006, 12:44

Για να αναβαθμίσετε το Ubuntu 6.06 Dapper Drake σε Ubuntu 6.10 Edgy Eft, ακολουθήστε τις παρακάτω οδηγίες:

1. Στο αρχείο /etc/apt/sources.list όπου γράφει την λέξη Dapper αντικατατήστε την με τη λέξη Edgy.

2. Εκτελέστε την εντολή

Κώδικας: Επιλογή όλων

apt-get update
3. Εκτελέστε την εντολή

Κώδικας: Επιλογή όλων

apt-get dist-upgrade
Φροντίστε να έχετε δικαιώματα root όσο εκτελείτε τα παραπάνω βήματα.
Programs must be written for people to read, and only incidentally for machines to execute.

Άβαταρ μέλους
agorf
Top Poster
Top Poster
Δημοσιεύσεις: 637
Εγγραφή: 07 Νοέμ 2005, 23:44
Distro: Debian testing
Τοποθεσία: Χαλκίδα
Επικοινωνία:

Ubuntu: Από Dapper Drake σε Edgy Eft.

Δημοσίευση από agorf » 26 Οκτ 2006, 20:34

Χρήσιμο, thanks.

Άβαταρ μέλους
Fuzz
Sr. Member
Sr. Member
Δημοσιεύσεις: 364
Εγγραφή: 22 Νοέμ 2005, 12:09
Distro: Debian
Τοποθεσία: Nowhere
Επικοινωνία:

Ubuntu: Από Dapper Drake σε Edgy Eft.

Δημοσίευση από Fuzz » 27 Οκτ 2006, 11:48

Και λίγο επικίνδυνο ειδικά για νέους χρήστες. Είναι πολύ πιθανό να παρουσιαστούν προβλήματα μετά το upgrade (ειδικά αν το σύστημα έχει πολλά πακέτα από διάφορα repos).
Καλό θα ήταν όσοι χρήστες δεν έχον μεγάλη εμπειρία να το αποφύγουν.
Boo!

Άβαταρ μέλους
agorf
Top Poster
Top Poster
Δημοσιεύσεις: 637
Εγγραφή: 07 Νοέμ 2005, 23:44
Distro: Debian testing
Τοποθεσία: Χαλκίδα
Επικοινωνία:

Ubuntu: Από Dapper Drake σε Edgy Eft.

Δημοσίευση από agorf » 27 Οκτ 2006, 12:35

Περισσότερα εδώ.

Άβαταρ μέλους
Indy
Jr. Member
Jr. Member
Δημοσιεύσεις: 87
Εγγραφή: 29 Νοέμ 2005, 15:29
Distro: Windows
Τοποθεσία: Θεσσαλονίκη
Επικοινωνία:

Ubuntu: Από Dapper Drake σε Edgy Eft.

Δημοσίευση από Indy » 27 Οκτ 2006, 14:18

Για νέους χρήστες προτείνεται να κατεβάσουν το νέο version του Ubuntu, να το "κάψουν" σε ένα cd και να το εγκαταστήσουν από την αρχή (αφού αποθηκεύσουν κάπου αλλού τα αρχεία που χρειάζονται).
Programs must be written for people to read, and only incidentally for machines to execute.

Άβαταρ μέλους
prokopuoi
Newbie
Newbie
Δημοσιεύσεις: 38
Εγγραφή: 10 Νοέμ 2005, 02:24
Distro: Windows
Τοποθεσία: Ιωάννινα

Ubuntu: Από Dapper Drake σε Edgy Eft.

Δημοσίευση από prokopuoi » 29 Οκτ 2006, 04:53

Όλα καλά και όλα ωραία με το νέο UBUNTU 6.10. Το έβαλα και παράτησα ποια το KDE και βλέπω πως είναι αρκετά όμορφο και το Gnome. Το θέμα όμως που προκύπτει για μένα που δεν είμαι και τόσο καλός χρήστης είναι η αναβάθμιση του παλαιότερου λειτουργικού (είχα Kubuntu Dapper 6.06 και δοκίμασα αν αναβαθμιστο με τη βοήθεια τον εντολών εδώ, αλλα τζίφος, έβγαζε σφάλμα στο apt-get dist-upgrade). Έστω όμως και να γίνει η εγκατάσταση του νέου Ubuntu απο κει και πέρα τι συμβαίνει με τα packages που έχεις βάλει στο μηχάνημα σου; Αν όντως δεν δουλεύουν σωστά τότε αυτό θα σε οδηγήσει στο να κάνεις ξανά format για να περάσεις το νέο Ubuntu Linux και μετά πάλι φτου και απο την αρχή στo apt synaptic κτλ. για το εκ νέου download των packages (αυτό συνέβη με εμένα..... :( )
Prokopis Georgopanos

The UoI Polymers' Group

Εικόνα

Άβαταρ μέλους
agorf
Top Poster
Top Poster
Δημοσιεύσεις: 637
Εγγραφή: 07 Νοέμ 2005, 23:44
Distro: Debian testing
Τοποθεσία: Χαλκίδα
Επικοινωνία:

Ubuntu: Από Dapper Drake σε Edgy Eft.

Δημοσίευση από agorf » 29 Οκτ 2006, 11:59

Δε ξέρω γιατί δε σου δούλεψε, πάντως αν εγκαταστήσεις το νέο Ubuntu από πάνω, μου φαίνεται λογικό να φύγουν τα packages που έχεις εγκαταστήσει ήδη.

Άβαταρ μέλους
kargig
Sr. Member
Sr. Member
Δημοσιεύσεις: 448
Εγγραφή: 08 Νοέμ 2005, 21:42
Distro: Windows
Τοποθεσία: Ioannina
Επικοινωνία:

Ubuntu: Από Dapper Drake σε Edgy Eft.

Δημοσίευση από kargig » 29 Οκτ 2006, 14:38

Άρθρο στο slashdot για τα προβλήματα αναβάθμισης από Ubuntu 6.06 σε 6.10...
http://linux.slashdot.org/linux/06/10/28/239258.shtml

Από ότι φαίνεται δεν είναι και λίγα τα προβλήματα...για να γίνει και άρθρο στο /. ...

Άβαταρ μέλους
prokopuoi
Newbie
Newbie
Δημοσιεύσεις: 38
Εγγραφή: 10 Νοέμ 2005, 02:24
Distro: Windows
Τοποθεσία: Ιωάννινα

Ubuntu: Από Dapper Drake σε Edgy Eft.

Δημοσίευση από prokopuoi » 29 Οκτ 2006, 17:22

Δε ξέρω γιατί δε σου δούλεψε, πάντως αν εγκαταστήσεις το νέο Ubuntu από πάνω, μου φαίνεται λογικό να φύγουν τα packages που έχεις εγκαταστήσει ήδη.
Μα φυσικά και είναι λογικό να μην υπάρχουν packages, αφού έπρεπε να κάνω format για να βάλω το νέο Ubuntu, πως θα ήταν δυνατό να σωθούν τα Packages??
Ίσως δε κατάλαβες σωστά αυτό εδώ
Έστω όμως και αν γίνει η εγκατάσταση του νέου Ubuntu απο κει και πέρα τι συμβαίνει με τα packages που έχεις βάλει στο μηχάνημα σου;
Eδώ λοιπόν εννοούσα οτι αν γίνει η "αναβάθμιση" σε 6.10 δεν είναι δυνατόν να δουλέψουν σωστά τα packages που είχα στην παλιά έκδοση του Ubuntu, και είναι κάτι σαν "ρητορική ερώτηση" αφού αυτό που θέλω να καταδείξω είναι ότι πρέπει να βρεθεί κάποια λύση για αυτό το θέμα, αλλα πια λύση δεν γνωρίζω. Έγραψα λοιπόν αυτό εδώ έτσι ώστε να το δει κάποιος με πολύ καλύτερες γνώσεις Linux απο εμένα και αν βρει κάτι να το πει..
Prokopis Georgopanos

The UoI Polymers' Group

Εικόνα

Άβαταρ μέλους
Indy
Jr. Member
Jr. Member
Δημοσιεύσεις: 87
Εγγραφή: 29 Νοέμ 2005, 15:29
Distro: Windows
Τοποθεσία: Θεσσαλονίκη
Επικοινωνία:

Ubuntu: Από Dapper Drake σε Edgy Eft.

Δημοσίευση από Indy » 29 Οκτ 2006, 18:23

Η αλήθεια είναι πως και εγώ αντιμετώπισα κάποια προβλήματα με την αναβάθμιση, τα οποία όμως αντιμετώπισα (σχετικά) γρήγορα. Τα βήματα που έγραψα στο πρώτο post, προφανώς δεν τα έβγαλα από το μυαλό μου, αλλά τα διάβασα σε επίσημους οδηγούς του Ubuntu.
Programs must be written for people to read, and only incidentally for machines to execute.

Άβαταρ μέλους
agorf
Top Poster
Top Poster
Δημοσιεύσεις: 637
Εγγραφή: 07 Νοέμ 2005, 23:44
Distro: Debian testing
Τοποθεσία: Χαλκίδα
Επικοινωνία:

Ubuntu: Από Dapper Drake σε Edgy Eft.

Δημοσίευση από agorf » 29 Οκτ 2006, 18:49

[quote="prokopuoi"]Eδώ λοιπόν εννοούσα οτι αν γίνει η "αναβάθμιση" σε 6.10 δεν είναι δυνατόν να δουλέψουν σωστά τα packages που είχα στην παλιά έκδοση του Ubuntu[/quote]
Αυτό πώς το συμπέρανες;

Άβαταρ μέλους
prokopuoi
Newbie
Newbie
Δημοσιεύσεις: 38
Εγγραφή: 10 Νοέμ 2005, 02:24
Distro: Windows
Τοποθεσία: Ιωάννινα

Ubuntu: Από Dapper Drake σε Edgy Eft.

Δημοσίευση από prokopuoi » 29 Οκτ 2006, 20:37

Indy εσύ μια χαρά πληροφορίες έδωσες... Απλά σε εμένα δεν δουλευαν όλα, και κατα την αναβάθμιση απο την έκδοση 5.10 στην έκδοση 6.06 τα ίδια είχα αντιμετωπίσει, και παλι είχα κάνει format σβήνοντας την παλιά έκδοση και βάζοντας την νέα...
Όσο για το άλλο θέμα bug, επειδή υπόθηκε παραπάνω ότι υπάρχει κάποια περίπτωση να συμβεί κάτι τέτοιο (να μην δουλεύουν τα packages), το έψαξα στo net και ειδικότερα στα ubuntu forums και είδα ότι πάρα πολύς κόσμος δεν βρίσκει λύση, και βλέπει να του βγαίνουν πολλά σφάλματα απο packages που είχε εγκαταστήσει στην προηγούμενη έκδοση... Βέβαια για έναν Advanced χρήστη του Linux σαν και εσένα Άγγελε αυτά ίσως να ήταν εφικτά...
Anyway, ένα πρόβλημα έθεσα στο forum, μη το τραβάμε άλλο με το πως το κατάλαβα, τι έκανα τι έρανα... Ξέρω ότι δεν είμαι πολύ πεπειραμένος χρήστης linux και οτι δεν έχω τις γνώσεις πολλών απο εδώ μέσα, και συν τις άλλοις δεν έχει νόημα γιατί ξεφεύγουμε απο το θέμα, που είναι να βρεθεί ένας τρόπο να γίνεται upgrade σε νεότερη έκδοση του ubuntu χωρίς να υπάρχουν σφάλματα και προβλήματα.. Επίσης ούτως ή άλλως έβαλα το Ubuntu μετά απο format και το έφτιαξα πλήρως, ίσως και σε καλύτερη κατάσταση απο ότι είχα πριν στο Kubuntu μου, και όλα είναι μια χαρά :) ..
Prokopis Georgopanos

The UoI Polymers' Group

Εικόνα

Άβαταρ μέλους
agorf
Top Poster
Top Poster
Δημοσιεύσεις: 637
Εγγραφή: 07 Νοέμ 2005, 23:44
Distro: Debian testing
Τοποθεσία: Χαλκίδα
Επικοινωνία:

Ubuntu: Από Dapper Drake σε Edgy Eft.

Δημοσίευση από agorf » 29 Οκτ 2006, 21:33

Δεν κάνουμε κάποιο διαγωνισμό, να καταλάβω τι εννοείς προσπαθώ. Anyways, τέλος καλό όλα καλά αφού τώρα δουλεύει...

Άβαταρ μέλους
kargig
Sr. Member
Sr. Member
Δημοσιεύσεις: 448
Εγγραφή: 08 Νοέμ 2005, 21:42
Distro: Windows
Τοποθεσία: Ioannina
Επικοινωνία:

Ubuntu: Από Dapper Drake σε Edgy Eft.

Δημοσίευση από kargig » 29 Οκτ 2006, 21:40

Λίγο offtopic..αλλά νομίζω πως είναι πολύ σημαντικό να είναι οσο το δυνατόν πιο ΚΑΘΑΡΟΓΡΑΜΜΕΝΑ τα posts σας.
Καταλαβαίνετε πόσο σημαντικό είναι να διαβάζετε τα posts σας ΠΡΙΝ πατήσετε submit... όσο πιο καθαρογραμμένα είναι τα posts τόσο πιο εύκολα θα σας βοηθήσει και κάποιος...κανένας δεν πρόκειται να μπει στη διαδικασία να σκεφτεί τι ίσως/μπορεί/θα ήθελε να πει ο άλλος για να του εξηγήσει και ποια είναι η λύση. Σκεφτείτε να ήταν και οι "λύσεις" τόσο κακογραμμένες όσο οι ερωτήσεις...

Ο Indy καλώς έδωσε κάποιες πληροφορίες...όσοι έχουν πρόβλημα καλό θα ήταν να πουν τι ΑΚΡΙΒΩΣ πρόβλημα αντιμετωπίζουν. Γενικότητες του στυλ "δεν έμπαιναν τα πακέτα"...δεν βοηθάνε κανένα. Το σωστό θα ήταν να ειπωθεί 1) ποιο πακέτο είχε πρόβλημα κατά την αναβάθμιση, 2) ποιο ήταν το error που βγήκε κατά το installation, 3) οτιδήποτε άλλο που πιστεύετε ότι θα μπορούσε να βοηθήσει, ώστε να γίνει καλύτερα αντιληπτό το πρόβλημα.

Σκεφτείτε να μπει ένας νέος χρήστης στο forum που θέλει να εγκαταστήσει κάποιο distro και να διαβάσει μια γενικότητα ότι "το Ubuntu δεν αναβαθμίζεται"...

Καθαρά posts με καθαρές ερωτήσεις για καθαρές απαντήσεις :)

Άβαταρ μέλους
prokopuoi
Newbie
Newbie
Δημοσιεύσεις: 38
Εγγραφή: 10 Νοέμ 2005, 02:24
Distro: Windows
Τοποθεσία: Ιωάννινα

Ubuntu: Από Dapper Drake σε Edgy Eft.

Δημοσίευση από prokopuoi » 29 Οκτ 2006, 23:49

Θέλω να ζητήσω συγνώμη, για όποιο μπέρδεμα προκάλεσα με τυχόν λάθη εκφραστικά στα Post μου (ήταν κυρίως λάθη κατα την πληκτρολόγιση μου και πρέπει να σταματήσω να γράφω κάποια στιγμή σε τυφλό, γιατί γράφω γρήγορα και γράφω τελικά μερικές κοτσάνες μέσα του στυλ "ακι", "αν" αντί του "να", "ειανι" κ.ο.κ.)..
Πάντως δεν καταλαβαίνω bug πως σκέφτηκες αυτό το post σου
πάντως αν εγκαταστήσεις το νέο Ubuntu από πάνω, μου φαίνεται λογικό να φύγουν τα packages που έχεις εγκαταστήσει ήδη.
σε απάντηση του δικού μου πρώτου post εδώ. Δεν εννοούσα πουθενά στο πρώτο μου post κάτι τέτοιο που κατάλαβες εσύ... Anyway...

Όσον αφορά το πρόβλημα και το πως ακριβώς έβγαινε δυχτυχώς δεν το συγκράτησα για να το κάνω paste εδώ. Σε γενικές γραμμές το πρόβλημα είχε ως εξής, αφού είχα κάνει τις μετατροπές στο source.list και είχα κάνει και apt-update, κατα την εκτέλεση της εντολής apt-get dist-upgrade, έβγαινε ένα μήνυμα που με ενημέρωνε ότι υπάρχει ήδη η τελευταία έκδοση του ubuntu (kubuntu) στο σύστημα μου (κάτι τυ still δε υπάρχε... Η ερμηνία που σκέφτηκα εγώ, αφού πρώτα έλεγξα αν ήταν σωστά τα όσα είχα κάνει στα πρώτα δυο βήματα του upgrade που περιέγραψε ο Indy στο πρώτο post του topic, ήταν ότι πολύ απλά δεν υπήρχε νέα έκδοση ακόμα για το Kubuntu...

Υ.Γ. Και πάλι sorry θα προσπαθήσω να γράφω καλύτερα, ή μάλλον πιο προσεκτικά και όχι πρόχειρα και γρήγορα..
Prokopis Georgopanos

The UoI Polymers' Group

Εικόνα

Απάντηση

Μέλη σε σύνδεση

Μέλη σε αυτήν τη Δ. Συζήτηση: Δεν υπάρχουν εγγεγραμμένα μέλη και 2 επισκέπτες